Statistics

165,442 members
198 posts
  • NickyC
    Newcomer - Level 1
    2020-06-07

    Just got my Plethora X5 and I'm really pleased with the quality of the effects.  I can cnnect to my PC via USB OK but no matter what I try (Android, iPhone iPad, etc) I can't get the Bluetooth connection to work.  Any ideas anyone?

    0 122
  • Vkpiii
    Contributor - Level 1
    2020-06-06

    Hi, 

     I'm having trouble uploading the new firmware upgrade into my plethora x5. Any help on the matter would be appreciated. 

    0 35
  • nadampski
    Contributor - Level 1
    2020-06-04

    I just noticed that the 1.1.52 firmware for the Plethora is now available, in case anyone's interested..

     

    https://www.tcelectronic.com/Categories/Tcelectronic/Guitar/Effects-Processors/PLETHORA-X5/p/P0D9M/Downloads

    read more...
    0 30
  • davidduts
    Contributor - Level 1
    2020-06-03

    Hello everybody,
    I have a problem with my mark V 90w head and the new TC Electronic Plethora.

    By testing the Plethora in that case guitar> Plethora> AMP R.A.S, but in the effect loop (in system 2 or 4) my sound is muffled.
    If I don't activate any effect and with the effect loop activated, the sound stays faithful (thanks to the true bypass system of the pedal, I imagine), but as soon as I activate an effect, it's as if I turn my tone knob all the way down to the bass and I lose at least 6dB.

    Side power lamp of the Mesa, I did not see any particular anomaly after inspection.

    I tested the Plethora on another amp (Marshall avt100x) and I also have a change of sound but here it is the opposite effect, more acute, less bass and a slight fuzz effect, as well as a small loss of sound.

    Thanks for your feedback

    read more...
    0 46
  • rawkinrobb
    Contributor - Level 1
    2020-06-02

    Hi. I've recently purchased this amp...which the website suggests is from Canada where I am, but their phone number would appear that they're overseas in Europe. Before they ship it out, they've sent me an email that the power supply it has is a 240v 50hz and would not work in my country. The power supplies online seem to be universal. Anybody have any ideas? Thanks in advance.

    read more...
    0 22
  • imandr
    Contributor - Level 2
    2020-06-01

    Hi TC Electronic! I emailed the customer support but they don't reply!

    0 97
    • imandr
      RexBeckett

      @imandr 


      I suggest that you raise a Care ticket for Technical Support explaining your problem. This is done by clicking on Support at the top of the page and then clicking the Create a Care Ticket button. This is only possible if you have completed all the required fields in your profile. Make sure that you fill-in every required field on the Care form.

      • May 31, 2020
    • imandr
      imandr

      VSS3 NATIVE does not work after updating Mac os 10.14.6. Please explain in more detail how to apply if I have a problem with the plugin VSS3 NATIVE

      Screenshot 2020-06-01 at 12.11.25.png
      • May 31, 2020
    • imandr
      TC-Claus

      Hi imandr,


      VSS3 Native should work just fine in macOS 10.14.6


      Would You explain in more detail the issues You're having? Have You installed the latest version?


      All the best and stay safe from


      Claus

      • June 1, 2020
    • imandr
      imandr

      Hi TC-Claus! I have the latest version installed. 

      Screenshot 2020-06-01 at 11.18.04.png
      • June 1, 2020
    • imandr
      TC-Claus

      I see it's a license issue - do You have access to the other computer? or do You want me to do a machine reset? (then please PM me Your iLok ID)

      • June 1, 2020
  • BryanRMiller
    Contributor - Level 2
    2020-05-30

    Having a great time with my new board. Quick question: I was under the impression a standard power supply such as my voodoo should power this. Am I wrong? My voodoo powers all other TCE pedals, but not this one. I have had to use the power supply that came with the unit.

    read more...
    0 118
    • BryanRMiller
      WilliamR

      Hello,


       


      The PLETHORAX5 requires a minimum of 600mA to operate. Power supplies like the Voodoo Lab Pedal Power 3 have dc taps that are 500mA each which would fall short. 

      • June 1, 2020
    • BryanRMiller
      BryanRMiller

      Ah, well explained. That's unfortunate for me. Thanks.

      • June 2, 2020
  • imandr
    Contributor - Level 2
    2020-05-29

    Hi TC Electronics! Please help me solve the problem. VSS3 NATIVE does not work after updating Mac os 10.14.6

    Screenshot 2020-06-01 at 11.18.04.png
    read more...
    0 39
  • justincharles
    Contributor - Level 1
    2020-05-29

    Can I get the Binson Echorec toneprint for my Flashback delay

    0 85
    • justincharles
      TC-Mike

      HI Justin,


      there is one available for the Flashback 2/ Flashback 2 x4 and Flashback2 Mini. Since it uses the new Tape delay algorithm introduced with Flashback2 , it is not available for first generetion Flashback delay models..


      You can get also quite convincing tape stylke delays with the Fflashback 1 thinning out the repeats with the two delay filters,


      Best regards,


      Mike

      • June 2, 2020
  • TheSomberLooper
    Contributor - Level 1
    2020-05-28

    Hi Ditto X4 Users,

    I'm interested in learning any Frippertronics type set ups using The Ditto x4. I was wondering if you can route the output of loop1 to the input of loop 2 for any appreciable regenerative looping?
    Also, Can one of the channels be used as a effects send and return? Or an ABy box separating effects chains for each loop channel?

    I'm just a 58 year old newbie who just wants to zoom sound-on-sound clouds of self-indulgent Ambient loops and washes. Please point me in the right direction. 

    read more...
    0 51
    • TheSomberLooper
      TC-Mike

      Hi,


      Frippertronic-style looping is not possible with the ditto X4 as the 2 Looper tracks cannot be assigned to individual /seperate outputs or routed into each other.


      Our new Plethora X5 pedal will get a looper with the forthcoming 1.2 firmware update (scheduled for summer)
      and if it supports multiple instances of it in the 5 available Fx slot that kind of workflow will be possible. 

      What in this regard is very interesting is that you can swap pedals around in the slots, so you could eg record with a Delay and reverb into Looper in slot 3 and then record the output of Looper 1 to a looper 2 in slot 4. Or you could use the Looper in Plethoras send and swap the loper around depending on which FX you want to record with. As said it is not available nor is feature set finalised, so check back in august and we will know more. 

      Best regards,

      Mike

      • May 28, 2020
Go to page