Statistics

165,426 members
175 posts
  • WorriedBarry
    Contributor - Level 1
    2020-06-10

    Hi folks, 

    I've recently picked up an original edition Flashback x4 second hand on the 'Bay. My current delay is a good old Boss DD-3, and I was wondering if the Flashback can get close to the glitchy short delay sounds (Radiohead/Klinghoffer) that the Boss is famous for?

    I know that the hold function is unique to the Boss DD series, but I reckon that I'd get a similar result from tap dancing with the looper. 

    Apologies if this has been asked before. Pedal hasn't arrived yet so I haven't had a chance to experiment. 

     

     

    read more...
    0 17
  • Vkpiii
    Contributor - Level 1
    2020-06-06

    Hi, 

     I'm having trouble uploading the new firmware upgrade into my plethora x5. Any help on the matter would be appreciated. 

    0 35
  • dubbeljoe
    Newcomer - Level 2
    2020-05-27

    Hi all,

    I just got a TCE M350 dual effect processor and it is lovely.

    Only problem I have is the software.

    How do I get a serial number for this free downloadable software?

    And why can I download it from the TCE website and there is no instruction how to get it working?

    Any ideas?

    thanks,

    William

    read more...
    0 37
  • Maximilain
    Contributor - Level 1
    2020-05-19

    Hi! I need to get a new battery for my M2000.

    Can tc send me one?

    0 29
    • Maximilain
      TC-Claus

      Hi Maximilain,


      We can't send You one but this is the battery You need: Renata CR2032RV


      All the best and stay safe from


      Claus

      • May 19, 2020
  • jonhollis
    Contributor - Level 3
    2020-05-10

    Hi - so it looks like the user on the mac osx app is different to the one on my iphone and indeed the one on my ipad. isnt there a way to log in and have one user on all devices. there doesnt seem to be a way to log in. just a tab called user.....

    read more...
    1 62
  • Sonichousepost
    Contributor - Level 1
    2020-04-12

    So I've been using my remote CPU and hardware Icon Version I with my upgraded Frame MKII for a while. I wanted the latest software before it was gone so updated fram to 8.5, net same etc no issue. When I sent the Icon to the update folder it loaded the software not compatible with MKI. Now I have a Remote Icon that can't get to load Software. Is there a way to reset the remote CPU back to birth, or was this a lethal mistake? The MKII Remote CPU has a reset button on front, the original does not. I'm not A big fan of the Software remote, compared to the hardware version.

    read more...
    0 59
    • Sonichousepost
      TC-Claus

      Hi Gary,


      It's a bit complicated process - You need to take out the PMCIA Card out and reload software with a card reader and USB Image Tool.


      I would suggest to find a Service Center near You


      All the best and stay safe from


      Claus

      • April 21, 2020
  • Doubleneck1
    Contributor - Level 1
    2020-04-10

    I’ve read about all of the Freezing issues on this faulty pedal but not until I bought one. Mine, like many others Freezes, but it does it when I turn the effects knob. A constant red light is on for the Effects LED and for Looper 1. Anyone else suffered this fate? This pedal is apparently a big mess. 

    read more...
    0 73
    • Doubleneck1
      Wolf53

      I had the same issue with my Ditto X4. Returned the device to manufacturer. They reseated the SD card internally and restored the firmware. If this were to happen again to my unit again, I believe I could have done this myself.


      Hope this helps!

      • April 10, 2020
    • Doubleneck1
      TC-Mike

      Hi Doubleneck,


      Please get in touch with our tech support regarding this. they will advice you on how to get your unit fixed.


      Please let them know the serialnumber, so they can check wether your pedal still had the 1st generation SD card that we no longer use..


      Cheers,


      Mike

      • May 6, 2020
  • hdeuxo
    Contributor - Level 1
    2020-04-10

    well hello, does anyone know if #tcelectronic will put. the "spectradrive bass"? because it is part of the toneprint series and it would be a plus for the bassists ^^". I just received mine.

    1 60
    • hdeuxo
      TC-Mike

      thanks for the feedback.  i pass it on to the team. Spectradrive doesn't saupport and Toneprint editing features as thr algorithms is based on the bass amp framwork.


      Cheers,


      Mike

      • May 6, 2020
  • GoDrex68
    Contributor - Level 1
    2020-04-09

    Is it normal for this pedal to make a faint pop pop noise when it's engaged? I don't hear it when I'm playing, but when I'm not I can hear it through my amp. Adjusting the rate and depth changes the speed/amount of pop sounds it makes. Just wondering if I return it and get another will I have the same issue. 

    read more...
    0 43
  • Jipooz
    Contributor - Level 3
    2020-04-09

    Hi everyone,

    New owner of a plethora x5, and very exited about it.

    I've got a question about the reverse delay : is there a way to hear only the wet signal (the reverse one) and not the main one ?

    I couldn't do that except in kill dry mode, but the problem is that when kill dry is on, you won't have a signal when the delay is off... No more sound !

    I sure missed something...

    I work in 4 cables method.

    Thanx for your suggestions !

     

    read more...
    0 155
    • Jipooz
      Jipooz

      Hi again !


      I tried everything, but can't find a way to bypass the straight signal. 
      Any idea ?


      Thanx !

      • April 14, 2020
Go to page